Heart-rate demo not working && cannot delete app


I have tried to run the heart rate demo on my jetson nano edge node, but cannot seem to get the output viewer. Once the application is running, the port is not linked:

Am I doing something wrong?

I also tried to delete the app after stopping it, and a ‘are you sure’ prompt came up. This might be a dumb question, but what is the ‘RESOURCE NAME’? I cannot find it anywhere.

With kind regards,

Hello again!

It is not linked, but it denotes what port is open. Take the IP of your node and append it with a colon and the open port, xxx.xxx.xx.xxx:5005 in the browsers URL. That should open the viewer!

The resource name is the name of the application. If you wish to delete it you can copy and paste the name in the modal or type it out to confirm deletion.


Hope that helps!

EDIT: If you are not on the same network, you will not be able to view the application, yet. As mentioned in the other thread, a (near) future release will remove that impediment.

Good morning!

Did my last post solve your issue @david ? If not please let me know so we can troubleshoot further.


Good morning!

Actually, that did not work for me. My apologies for the late reply, I actually encountered some issue with Docker and Docker-Daemon on my Nano. I am not sure if it is connected to the iofog agent but I have been trying to fix this what seems to be a version control issue.


No worries.

I suggest confirming the container is forwarding to the right port. Try running docker ps and see if the app’s port is 5005:80

I would also check if the browser is forcing https. You may need to manually remove the “s”.

Let me know if any of this resolves it or if your findings provide new info.

Hi Alex,

So I have have got my Nano up and running again and have checked that the app’s port is 5005:80; result of docker ps:

“darcyai/heart-rate-demo-viewer:1.0.0 ‘docker-entrypoint.s…’ 34 minutes ago Up 33 minutes>80/tcp, :::5005->80/tcp”

I also tried removing the “s” in http(s) but still no luck :/.

Is there anything else I could be doing wrong?

Hmm. Have you checked the firewall(s) to see if that port is blocked?

Hey @david hope you had a nice Holiday break! Was wondering if you were able to check the firewall and if that was the issue.